The pastview System is a web-hosted solution, which means that it can be accessed from anywhere that has an internet connection. Your users (staff, volunteers, researchers etc.) can access the system from work, home, on the train or on a sunny beach in Barbados (if they really want to that is!).
 

Compatible with all major web browsers

Because it is browser based there are no specific hardware requirements for PastView, it can be accessed simply by any standard contemporary PC, tablet or smartphone. But it does have certain browser requirements to enable all the functionality that the system offers.

PastView’s minimum requirements for optimum experience are:

Desktop:

  • Chrome version 50 and above
  • Safari version 10.1 and above
  • Firefox version 50 and above
  • Internet Explorer version 11 and above
  • Edge version 21 and above

Mobile:

  • Chrome on Android 4 and above
  • Safari on iOS 10 and above